15th June 2021

Core Network Fremont Power Outage FMT2

We are Investigating an issue in FMT2.

Update 03:40: There appears to be a power outage at FMT2, our redundant upstream providers report the same issue, redundant connected gear seems to be affected as well.

Update: 04:12 Power seems to be restored, all links are up again.