3rd December 2025

Core Network Barcelona Issue Barcelona

We are seeing an issue in Barcelona.

We have a ticket open with our datacenter regarding this issue.

Update: A power maintenance has caused an issue with one of our switches, we are working with the DC to resolve this issue.

Update: The Incident has been resolved.